Table of Contents
MAC OS X
Eclipse shortcut
- Keyboard shortcut for code completion in Eclipse on Mac OS X :
Eclipse Preference→General→Keys→Content Assist
Reference:
http://stefaanlippens.net/code_completion_shortcut_eclipse_osx
- Use ctrl+F11 to roate the Android Emulator http://stackoverflow.com/questions/2618967/switching-to-landscape-mode-in-android-emulator
SQLite frontend Manager
- MesaSQLite Download http://www.desertsandsoftware.com/?page_id=99
- SQLite database browser
More information refer to http://stackoverflow.com/questions/100959/mac-sqlite-editor/14228275#14228275
XCode
Use cmd + shift + f for complete Xcode search.
Enable/Disable spotlight service
cd /System/Library/LaunchDaemons sudo launchctl load -w com.apple.metadata.mds.plist launchctl unload -w com.apple.metadata.mds.plist mdutil -a -i on /
shortcut
Lock the screen
ctrl+shift+右上角的推出键
ntfsfree
On Mac OS X 10.9, install the ntfs-free for ntfs write, it works now, fuck Apple.
http://sourceforge.net/projects/ntfsfree/files/?source=navbar
mount --bind
If you are the linux user, you should know the powerful mount –bind command, because you don't need to copy&paste the files to the physical directory, but the behaviour should be the same with this command, you can dynamic share some files to the specific directory, and remove it after finish it.
But on Mac OS X, the mount command doesn't support the option “–bind”, so after some google, I find there has one workaround for this, use the bindfs(http://bindfs.org/).
So first download the source code from here:
Compile and make install it.
./configure && make && sudo make install
Probably, you need install the osxfuse first: http://sourceforge.net/projects/osxfuse/?source=typ_redirect
Then enjoy it
bindfs all_pictures/ /Volumes/Backup/百度云同步盘/all_pictures
Or you want to unbind it
umount /Volumes/Backup/百度云同步盘/all_pictures